Results 1 to 3 of 3

Thread: Fungus on red tiger lily

  1. #1
    Join Date
    Sep 2008
    Location
    between Sac and Reno
    Posts
    163

    Fungus on red tiger lily

    I have a white fungus (fuzz) in my to bulbs. They have sprouted but I am not sure what to do about the fungus. It looks more like a mold the an algae. Here is a pic. I have them in my main tank and nothing else has this stuff. Should I remove the bulbs? Treat them how? or ignore them? Here is a pic. The one on the left has more of it on top. Sorry I could not get a better pic. I am so bad with aquarium shots.

    Last edited by crystalview; 09-19-2008 at 05:49 AM.
    12 ADF's, discus, 2 oto, pair golden rams No Co2, Use EI, generic Excel, Eheim 2126, 18w UV, 96w 6700k raised 4" above tank (6hrs) 75g tall 2 mini fans / bubble wand more O2 deep tank.

  2. #2
    Join Date
    Sep 2008
    Location
    between Sac and Reno
    Posts
    163
    Today I noticed the same white growth on the piece of squash I placed in the tank 15hrs before. Got the squash out of there.
    12 ADF's, discus, 2 oto, pair golden rams No Co2, Use EI, generic Excel, Eheim 2126, 18w UV, 96w 6700k raised 4" above tank (6hrs) 75g tall 2 mini fans / bubble wand more O2 deep tank.

  3. #3
    I have had the white growth on lily bulbs and aponogeton bulbs and it really didn't seem to bother anything. If it gets too bad though, I would remove them.
    Littlecich

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •